EkkoSoft Platform - US region - degraded performance

Incident Report for EkkoSoft

Resolved

Estate Page is now showing rooms online as before. A new notification will be created when the next update will take place to bring in the features of 9.2
Posted Oct 22, 2025 - 09:24 BST

Update

We are continuing to investigate this issue.
Posted Oct 22, 2025 - 09:22 BST

Investigating

We are currently experiencing degraded performance on the estate page for the US instance following the update which took place yesterday. All other services are running as normal - data access within sites, rooms, data aggregation for reporting, alerting and public API are all operational, however the estate page is currently showing as all sites offline. We are looking into a fix and hope to have this resolved as soon as possible. Apologies for any inconvenience.
Posted Oct 21, 2025 - 21:52 BST
This incident affected: EkkoSoft US (EkkoSoft Web Platform (US)).